Overview:
Why are Products not displaying for Call Details (Detailing Priority) on the Call page by default? There are available products to be selected in Add Other... and Add Section.
Root Cause:
If the user has at least Read access to the Favorite_vod__c field in the My_Setup_Products_vod__c object, but no products are starred as Favorites, no products display by default.
Solution:
Remove Read access from Favorite_vod__c field in the My_Setup_Products_vod__c object if not using Detail Favorites.
Related Documentation:
CRM Help Documentation: Detailing Products on the Call Report