Overview:
A Manager user cannot view or select a Rep user in My Setup. The Manager user is in a higher Territory.
Root Cause:
The Manager user is assigned to the Rep user Territory which makes the Rep user hidden for the Manager.
Solution:
The Manager user must not be assigned to the same Territory as the Rep user.
The Rep user is visible to the Manager user if the Manager user is only assigned to a higher Territory.
Related Documentation:
CRM Help Documentation: Using the My Setup Page