Overview:
When performing a synchronization with the Veeva CRM Offline application, a user receives an error in the Activity log: Didn't understand relationship <Field__r> in field path.
Root Cause:
This is referenced in a WHERE clause defined in a VMobile Object Configuration (VMOC).
<Field__c> is a lookup field on the object listed. The error occurs because the user, who performs synchronization, does not have access to the object that the field references.
Solution:
To correct the error, do the following:
- Assign the user access to the object that the field references.
- Clear Veeva cache.
- Perform Sync.
Related Documentation:
N/A
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