Overview:
Affiliations are not appearing as Suggested Attendees offline when creating a Call. Affiliations are displaying by default online as expected.
Root Cause:
The Enable Child Account Veeva Setting is checked without the user having the correct permissions.
Online, CRM checks whether the Child Accounts feature is enabled on Calls with the following:
- Enable Child Account Veeva Setting is true
- User has Field Level Security (FLS) to the Parent_Child_Name_vod__c field on the Child Account object (Child_Account_vod_c)
- User has FLS to the Child_Account_vod__c field on the Call object (Call2_vod__c)
Offline, CRM (iRep) only checks for the following:
- Enable Child Account Veeva Setting is true
- User has at least Read permission to the Child_Account_vod_c object.
Solution:
Disable the Enable Child Account Veeva Setting, from Custom Settings --> Veeva Settings.
Related Documentation:
CRM Help Documentation: Call Reporting with Child Accounts
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