Overview:
Admin users can now configure Consent using Content Types instead of capturing consent at the Product level.
Content Types are categories the admin user creates in the Content Type object. Content Types offer an alternative to the typical Detail Topic creation process in the Product Catalog, allowing greater flexibility when capturing consent.
But, when a user has unsubscribed the Content Type from the link in an approved email, the unsubscribed content type is not reflected in Consent Capture page, the status is still Opt-In.
Root Cause:
Although the user has set up Consent Capture for Content Types, the unsubscribe process is still creating records for Products.
Solution:
The user needs to update the Unsubscribe_vod record:
- Set Consent_Level_vod = Content_Type_vod.
- The Unsubscribe_Products_vod records under the Unsubscribe_vod records need to be looking up to a Content_Type_vod record and not to Product_vod.
- The Detail_Group_vod field needs to be empty.
Related Documentation:
CRM Help Documentation: Unsubscribe by Content Type