Overview:
A user encounters the following message when using the API Library:
com.veeva.clm.getSurvey_Object: Unable to get Account ID. Code: 1112. Message:getDataForCurrentObject: getDataForObject called with object which is not available in preview mode: Account.
Root Cause:
The message indicates the presentation is opened directly from the Media tab of the Navigation Panel. Therefore, no Account is associated to the CLM Presentation.
Solution:
An account has to be associated prior to viewing the CLM Presentation.
- Navigate to an Account Detail.
- Open the CLM Presentation.
Related Documentation:
CRM Help Documentation: API Developer Library