Overview:
Despite all configuration steps are completed, the Request Receipt checkbox is not appearing on the Consent Capture page.
Root Cause:
The affected user is missing Field Level Security (FLS) Read access to the Country_vod__c field on the Multichannel_Route_vod__c object.
Solution:
Grant FLS Read access to the Multichannel_Route_vod__c.Country_vod__c field:
- As a System Administrator, open the user profile.
- In the Field Level Security section, click View next to Multichannel Routing.
- Click Edit and give Read access to the Country field.
- Click Save.
- Clear the Veeva Cache.
Related Documentation:
CRM Help Documentation: Consent Capture Overview