Overview:
Account tactics of a shared account plan are not visible to the Account team members.
Root Cause:
Account plan Sharing is based on the following object hierarchy order:
Account Plan --> Plan Tactic --> Account Tactic --> Call Objective.
If one or more of the Account Plan Objects of the hierarchy is not used the account team member sharing does not properly cascade to the object below.
For example, if the Account plan is not using Plan Tactics, the Account Team Member sharing does not properly cascade to the Account Tactics.
Solution:
Veeva has a Custom Veeva Setting which allows the Account Plan Object Hierarchy to be defined.
The Account_Plan_Object_Hierarchy_vod Veeva Setting defines the Account Plan Object Hierarchy used for Account Plan sharing. It should contain a Comma delimited list of object API names and relationship names used to determine the Account Plan object hierarchy.
Each value should be the name of an object followed by the name of the relationship separated by a dot. The first object.relationship is considered the top of the hierarchy and the last at the bottom.
The default hierarchy is:
Plan_Tactic_vod__c.Account_Plan_vod__r, Account_Tactic_vod__c.Plan_Tactic_vod__r, Call_Objective_vod__c.Account_Tactic_vod__r
Example:
If Plan Tactic and Call Objective are not used, but is required sharing the Account Tactics, the Account_Plan_Object_Hierarchy_vod custom Veeva Setting needs to be updated to:
Account_Tactic_vod__c.Account_Plan_vod__r
Once the custom Veeva Setting is updated, it is required to clear the Veeva Cache.
Related Documentation:
CRM Help Documentation: Account Plan Sharing
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