Overview:
A user trying to login to Vault is receiving an error: User with Federated ID [] was not found.
Root Cause:
The Vault SAML Profile is setup to use a user's Federated ID as the identifier between the Identity Provider and Vault. The value within the brackets of this error message is not a valid Federated ID for a user in the Vault.
Solution:
Be sure that the uid attribute in the SAML Response is holding the desired value, which needs to match with the user's Federated ID value in Vault.
Related Documentation:
Vault Documentation: About SAML User ID Types