Overview:
When a Business Reply Card (BRC) Product is added and the Ship to Location field is filled out on the Call Report, the Call cannot be Saved or Submitted Online.
The page freezes and the Save or Submit button does not respond.
Root Cause:
Field Level Security (FLS) is missing on the Restricted_Product_vod__c field on the Account object.
Solution:
In order to resolve the issue FLS must be added to the Restricted_Product_vod__c field on the Account object in the User Profile or Permission Set as it is required in the Organization.
Related Documentation:
CRM Help Documentation: Ship to Business Location