Overview:
The language of the Offline CRM application of the end user is other than English. Upon trying to search for Account record names using the My Accounts Search Box offline, the results are inconsistent.
Symptoms of the issue include typing certain special characters of the language which do not return consistent Search results or any results at all. The same behavior can also be observed by using English characters on particular Account names.
Root Cause:
The Salesforce Locale value is not matching with the Language value of the end user.
Solution:
In order to resolve the issue, be sure that the Locale value setting matches with the Language value of the user record of the end user.
Related Documentation:
CRM Help Documentation: My Accounts Overview