Overview:
A user cannot select the desired Business Account on the zvod_Business_Account_vod__c (Location) field when a Call is being recorded. Its name is displayed in gray:
Root Cause:
The Do Not Call? (Do_Not_Call_vod__c) field is set to Yes_vod for the Business Account, making it ineligible for Call recording.
Solution:
The field value on the Business Account should be modified to No_vod, so Calls can be recorded for the record, and it can be selected as the location in the Call of the Person Account.
Related Documentation:
CRM Help Documentation: Selecting the Call Location