Overview:
Despite the provided configuration in the Managing Call Cycles documentation, Copy to Call Cycle cannot be applied to the daily or weekly Schedule.
Root Cause:
Copy to Call Cycle does not support All-Day calls. This is why Field Level Security (FLS) is required on the Call2_vod object to the Call_Datetime_vod field.
Solution:
In order to Copy to Call Cycle, add FLS to the Call_Datetime_vod field on the Call2_vod object.
Related Documentation:
CRM Help Documentation: Managing Call Cycles