Overview:
By default, the One-click Completion feature does not require any information to be entered for a Call Objective when the user records a Call. However, additional Call Objective fields are still displayed on the Call page layout Online.
Root Cause:
Only Read Field Level Security (FLS) is provided for the One_Click_Completion_vod field on the Call Objective object.
Solution:
Once Edit FLS is granted as well, the expected behavior occurs. This means that the extra fields are not displayed on either of the platforms.
Related Documentation:
CRM Help Documentation: Call Objective Types
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