Overview:
Upon accessing the Future Territory Alignments tab in Veeva CRM with an end-user (Rep or Manager), the following error message is displayed:
An error has occurred: This territory cannot be accessed at this time.
The error message appears offline as well.
Root Cause:
This error message is caused by a misconfiguration either in Veeva Align or in Veeva CRM.
Review the following:
- The Modeling Project is in the Feedback Review State
- The Model Territory, including the Child Model Territories, are in the appropriate Lifecycle State (Feedback, Territory Feedback Complete)
- The Roster Member (Rep User or Manager User) has a corresponding Model Roster Member Territory in the Veeva Align Modeling Project
- The Multichannel (MC) Cycle associated to the Model Field Force is in the Feedback Review Lifecycle State
- The Model Approval Mapping records exist, meaning that the approval process is configured for the relevant Model Field Force(s)
- In the approval process configuration, the Model Territory Hierarchy levels match the hierarchy levels defined in the Approval Process of the Model Field Force(s) Manager and Field Rep
- The territory settings record in Veeva CRM has the Align Territory Feedback Mode populated
- For offline platform use, the Territory Settings VMobile Object Configuration (VMOC) record exists and is activated.
Note: The feedback process only allows roster members (Reps) to provide feedback if they are assigned to a Territory Model on or before the planned publish date time of the modeling project.
Solution:
These configurations are required to be in place.
Be sure to run the following in the event any changes were made:
- Recalculate territory data on the Modeling Field Force. In the event, the feedback period is not started, run an assignment preview and assignment commit on the Model Field Force.
- Clear the Veeva cache.
- Run a database refresh on the offline platform.
Related Documentation:
Align Help Documentation:
Knowledge Article: