Overview:
Phone Numbers captured on Medical Inquiry records are truncated to 30 characters on the corresponding Medical Inquiry Audit records.
Root Cause:
Standard Salesforce Phone type fields have a character length of 40.
The Phone_vod field on the Medical_Inquiry_Audit_vod object is a standard Text field and is created with a standard length of 30 characters. Phone values greater than 30 characters are truncated when copied to the Medical_Inquiry_Audit_vod record.
Solution:
All new Veeva Orgs have a character length of 40 for the Phone_vod field on the Medical_Inquiry_Audit_vod object.
Existing Customers can increase the length of the Phone_vod text field on the Medical_Inquiry_Audit_vod object to 40 characters.
Related Documentation:
CRM Help Documentation: Components of a Medical Inquiry