Overview:
Account Plan Dashboard displays a blank, gray screen.
Root Cause:
The Account Plan Sharing feature now uses the org-level Account_Plan_Object_Hierarchy_vod Veeva Setting and shares records with team members based on the defined hierarchy.
Example:
An Account Plan Hierarchy might be defined with a model where an Account Plan consists of several Account Tactics with multiple Action Items linked to them. This is represented with the following value in the org-level Account_Plan_Object_Hierarchy_vod custom setting:
- Account_Tactic_vod__c.Account_Plan_vod__r,Action_Item_vod__c.Account_Tactic_vod__r
If Account Plan consists of several Account Tactics with multiple Call Objectives:
- Plan_Tactic_vod__c.Account_Plan_vod__r,Account_Tactic_vod__c.Plan_Tactic_vod__r,Call_Objective_vod__c.Account_Tactic_vod__c
The root cause can be that Account Plan Object Hierarchy is using Call Objective which requires the user to have access to it.
Solution:
There are two possible solutions:
- Provide Read access to Call Objective
or,
- Change the Account Plan Hierarchy to not include Call Objective.
Related Documentation:
CRM Help Documentation: Account Plan Dashboard
Send us your feedback: We are always looking for feedback to help improve our Knowledge Base! Please let us know if this article is helpful or provide feedback on how we can improve your experience by clicking here.