Overview:
The orange bar on top of the home page is there, but the menu item does not appear.
Root Cause:
One cause of this problem is the user does not have access to the Territory_Insights_vod record type in the HTML_Report_vod object.
Another cause is the user does not have the VMOC for HTML_Report_vod object.
Solution:
Assign the user access to the Territory_Insights_vod record type either through profile or permission set. In addition, if it is not already created, create the VMOC for HTML_Report_vod and activate it.
Related Documentation:
CRM Help Documentation: Configuring MyInsights for Admins and End Users