Overview:
While creating contracts, a user receives an error: This user is not allowed to create contracts.
Root Cause:
The error message displays if the user (Contract Administrator) does not have CRUD permissions to the Contracts, Contract Lines, and Contract Partner objects.
Solution:
Provide Read, Create, Edit, and Delete permissions to the following objects through the user's profile or permission set:
- Contract
- Contract Line
- Contract Partner
Note: Contract Administrators must have edit permission to Contract_Line_vod and FLS edit permission to the Lock_vod field on both Contract_vod and Contract_Line_vod to be able to activate Contracts.
Related Documentation:
CRM Help Documentation: Configuring Contracts
Send us your feedback: We are always looking for feedback to help improve our Knowledge Base! Please let us know if this article is helpful or provide feedback on how we can improve your experience by clicking here.