Overview:
When opening a Child Account record from the Parent Account's Members related list, the following error occurs: Unable to access this feature. Your account does not have all the required permissions.
This error occurs despite the fact that the user has access to Accounts and the corresponding Visualforce page.
Root Cause:
The user is missing Object Level Security (OLS) on the Veeva Message object.
Solution:
To prevent the error, do the following:
- Grant the user permission on the Message_vod__c object.
- Clear Veeva cache.
Related Documentation:
CRM Help Documentation: Working with Child Accounts