Overview:
When the Save for Later feature is used in CLM without an Account an Unassigned Presentation is generated in My Schedule. The function saves the Presentations as Multichannel Activities. As soon as the end-user syncs, this Presentation disappears from the user's device.
Root Cause:
A common cause for this problem is that the Where Clause of the Multichannel Activity VMOC does not include records where Saved_For_Later_vod__c =true. The Multichannel Activity record is synced up to the SFDC database, but the records disappear since the VMobile Object Configuration (VMOC) filters them out.
Solution:
- Edit the VMOC Where Clause for the Multichannel_Activity_vod object in the following manner if the CLM Save For Later Feature is used without Engage for Portals/CoBrowse:
WHERE (OwnerID = @@VOD_SF_USER_ID@@ AND RecordTypeId = @@VOD_RECORDTYPE_ID:Multichannel_Activity_vod__c.CLM_vod@@ AND Saved_For_Later_vod__c = true)
- Edit the VMOC Where Clause for the Multichannel_Activity_vod object in the following manner, if the CLM Save For Later feature is used with Engage for Portals/CoBrowse:
WHERE ((Start_DateTime_vod__c>=LAST_N_DAYS:30 AND Account_vod__r.Name != null AND RecordTypeId IN (@@VOD_RECORDTYPE_ID:Multichannel_Activity_vod__c.Engage_vod@@, @@VOD_RECORDTYPE_ID:Multichannel_Activity_vod__c.Cobrowse_vod@@)) OR (OwnerID = @@VOD_SF_USER_ID@@ AND RecordTypeId = @@VOD_RECORDTYPE_ID:Multichannel_Activity_vod__c.CLM_vod@@ AND Saved_For_Later_vod__c = true))
Related Documentation:
CRM Help Documentation: Associating Accounts with Tracked CLM Activity