Overview:
When clicking the Refreshing Validation Rule Data button on the Validation Rule Administration Page in CRM Online, a warning occurs:
<Validation Rule> is not supported.
Root Cause:
This indicates that the Validation Rule is not supported. One possible reason is that the unsupported $Setup Global Variable is used in the Validation Rule.
Example:
$Setup.xxx_Settings__c.xxx__c
Currently, the following Global Variables are partially supported as indicated:
- $Setup
- $Setup.Veeva_Settings_vod
- $Setup.Network_Settings_vod
- $Setup.Approved_Email_Settings_vod
- $Setup.Concur_Settings_vod
Solution:
To correct the error, do the following:
- Correct the Validation Rule.
- Refresh Validation Rule Data again.
Related Documentation:
CRM Help Documentation: Offline Validation Rules
Send us your feedback: We are always looking for feedback to help improve our Knowledge Base! Please let us know if this article is helpful or provide feedback on how we can improve your experience by clicking here.