Overview:
A user attempts a Vault login using Microsoft Edge™ when an error occurs: Can't connect securely to this page.
Root Cause:
Vault requires Transport Layer Security (TLS) 1.2 for a secure connection. However, in some browser versions, Microsoft Edge™ has TLS 1.2 disabled by default.
Solution:
To solve this issue, TLS 1.2 in Microsoft Edge™ needs to be enabled.
- In the Windows menu search box, type Internet options.
- Under Best match, click Internet Options.
- In the Internet Properties window and on the Advanced tab, scroll down to the Security section.
- Enable (Check) the Use TLS 1.1 and Use TLS 1.2 checkboxes.
- Click OK.
- Close the browser and restart the Microsoft Edge™ browser.
Related Documentation:
Vault Help Documentation: