Overview:
A blank space displays above the Name field in New Account Wizard in CRM iPad.
Root Cause:
There is a Data Change Request (DCR) Field Type defined for the Account Object and LastName field which is not restricted to certain Record Types. Hence, it applies to all Record Types including a hospital Record Type.
The Page Layout that is assigned for the hospital Record Type does not have the LastName field (which makes sense only for Person Account types) on it. Since CRM iPad cannot find that field on the page layout, it is not displaying anything.
Solution:
Modify the configuration according to the guide below so that the DCR Field Type does not get applied to the Account Record Types which are not Person Account types.
Related Documentation:
CRM Help Documentation: Configuration of DCR Controlled Fields