Overview:
The user has active Sample Lots in My Samples page. However, when recording a Call, the user is not able to find these Sample Lots in Call Report page in CRM.
Root Cause:
The Sample field of Sample Lot does not match the name of the Sample.
For example, actually, there are two spaces between Test and Sample. There is an extra space in the Sample field of Sample Lot.
The extra space does not display unless the user edits it.
Solution:
Edit the Sample field and remove the extra space.
Related Documentation:
CRM Help Documentation: N/A