Overview:
Error: Validation Errors While Saving Record(s) - When submitting an Order in CRM.
The detailed error is:
There were custom validation error(s) encountered while saving the affected record(s). The first validation error encountered was "You may not update or delete a locked Order or any of the related data.".
Root Cause:
The documentation Order Management Approval Process covers the recommended field values:
For Approval, Override_Lock_vod is True.
But the user does not have this included in the approval actions for the approval process.
Solution:
- Navigate to: Setup --> Build --> Create --> Workflow & Approvals
- Include Override_Lock_vod is True in the approval process.
Related Documentation:
CRM Help Documentation: Order Management Approval
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