Overview:
When creating Orders for some Accounts, the user is not able to see relevant products in the Order Line in CRM iPad. However, they are visible online.
Root Cause:
The Wholesaler Account Partner has a name of XXX XXX, but the Price Book is configured with Wholesaler_vod__c = Xxx Xxx. However, in CRM iPad, this is a case sensitive search. So they do not match.
Solution:
Change the name so they match.
Related Documentation:
CRM Help Documentation: Linking Price Books to Wholesalers