Overview:
When opening an Approved Email that is sent to a @gmail.com email address, the Opened Activity record is not recording the correct Client OS and Client Name.
Root Cause:
For security reasons, Google caches the images in any email sent to Gmail onto a local server. Opened events are tracked when the images in the emails are rendered. When emails sent to a Gmail address are accessed, they most likely have the tracking information of where the image is rendered on Google's servers and not the actual recipient's details.
Solution:
This is not in Veeva's control. Tracking can be confirmed by sending a test email to a non-gmail email address.
Related Documentation:
CRM Help Documentation: How are Gmail opens reported within Email Analytics