Overview:
The Address Inheritance process does not copy the address to the Child Account if the Controlling Address does not have a Record Type set, even though the rest of the data is correct and no failures are shown on the Apex Job page.
Root Cause:
This is working as designed. Even though no failures are shown on the Apex Job page, the Controlling Address must have a Record Type.
Solution:
The Record Type of the Controlling Addresses must be changed to have values other than null (the master Record Type).
Related Documentation:
CRM Help Documentation: Address Inheritance Support
Knowledge Base Article: Address Inheritance Does Not Create or Update the Address Records in CRM Online