Overview:
The Last syncing information of User object is not updated after successful sync in CRM.
For example:
- Last iPad Connect
- Last iPad Connect Version
- Last iPad iOS Version
- Last iPad Sync
Root Cause:
- The user has no permission or only has Read permission on these fields.
- This also can happen if there is a Validation Rule on User is preventing the changes during sync.
Solution:
To grant the Edit FLS permission:
- Navigate to: Setup --> Administer --> Manage Users --> Profiles
- Find the user's profile
- In the section of Field-Level Security (FLS), find User object and then grant FLS Edit permission accordingly.
Refer to the Knowledgebase (KB) article to check the validation rules on a user by using Debug Logs.
Related Documentation:
KB Article: How to Enable Debug Logs for a User in CRM?