Overview:
The notification email is not received after publishing a Survey through the use of the VEEVA_BATCH_SURVEY_PUBLISH Apex Class in CRM Online.
Root Cause:
One possible reason is that the Territories_vod__c field is placed on the corresponding Survey page layout.
Solution:
Replace the Territories_vod__c field with the Territory_vod__c field by following the steps below:
- Navigate to: Setup --> Create --> Objects ->- Survey.
- Navigate to Page Layouts.
- Select the relevant page layout and click the Edit button.
- Enter Territory_vod__c in the Quick Find.
- Replace the Territories_vod__c with Territory_vod__c in the relevant section.
- Save the change.
- Clear Veeva Cache.
Note:
- Cannot have both the Territory_vod and Territories_vod fields on the page layout.
- The Territory Selector is only supported when using the Veeva MC Engine to publish Surveys.
Related Documentation:
CRM Help Documentation: Publishing a Survey