Overview:
The CLM Administration Console displays the following error after a synchronization:
Error while upserting record xxxxxxxxxx:xxx::Approved_vod, Cause: Directory record must have Record Type = CLM_vod.

Root Cause:
The corresponding directory record in CRM does not populate the Record Type field with CLM.

Solution:
To avoid this error, do the following:
- Change the Record Type field of the corresponding Directory record to CLM.
- Perform a CLM synchronization again.
Related Documentation:
CRM Help Documentation: Integrating CRM and Vault for CLM
Send us your feedback: We are always looking for feedback to help improve our Knowledge Base! Please let us know if this article is helpful or provide feedback on how we can improve your experience by clicking here.