Overview:
When adding an Attendee to an Event in CRM, the user encounters the following error:
Event_Attendee_vod: execution of BeforeInsert caused by: System.DmlException: Insert failed. First exception on row x first error: CANNOT_INSERT_UPDATE_ACTIVATE_ENTITY, VOD_EM_ATTENDEE_BEFORE_INS_UPD: execution of BeforeInsert caused by: System.QueryException: List has more than 1 row for assignment to SObject Trigger.VOD_EM_ATTENDEE_BEFORE_INS_UPD: line xx, column x: [] Trigger.Event_Attendee_vod: line xxx, column x
Root Cause:
A trigger has the error because the user's Org has multiple rows in the Events_Management_Settings_vod__c object.
One of them is assigned to the Org level. The second one is assigned to a User.
Solution:
At the current version of the trigger, Veeva supports only one Events_Management_Settings row.
The second one (for the user) must be deleted.
Related Documentation:
CRM Help Documentation: Event Attendees
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