Overview:
After scheduling an Engage Meeting for a person account, the user can only select one recipient when sending the invitation. There are other accounts selected as Attendees.
Root Cause:
This is currently expected behavior. When recording a Call against a personal account and making it an Engage Meeting, only one Remote Meeting ID is generated for that personal account. This occurs even if there are other personal accounts as attendees. Send Invitations only brings in the original person account.
It is recommended that the customer record a Call against a business account using Unique Activities. Then, each of the personal accounts added to the Call have their own Remote Meeting ID and each is added as a recipient on Send Invitations.
Solution:
There is an enhancement for Engage Meeting planned to support this scenario where the call or remote meeting is scheduled against a personal account and other personal accounts are added. A unique Remote Meeting ID is to be generated for each personal account.
Related Documentation:
CRM Help Documentation: Sending Engage Meeting Invitations via Approved Email