Overview:
The disclaimer is not visible on the Medical Inquiry (MI) Page on CRM iPad. However, it is visible online when the user creates a Medical Inquiry.
Root Cause:
This issue occurs if the user has access to the Signature_Page_vod object and a VMobile Object Configuration (VMOC) for it, but there is no MI-specific Signature Page Record.
When a user has access to a Signature Page object, the disclaimer on the MI is derived from the MI-specific signature page record and not from a Veeva message. This is working as designed.
The same is true for other signature pages e.g Call Sample Signature page, Call Detail, Call Acknowledgement, Sample Opt-In.
Solution:
The solution is to create an MI-specific signature page record accordingly.
Example:
Related Documentation:
CRM Help Documentation: Customizing the Signature Page