Overview:
When attempting to view an event team member record, the page will not load and it will say
Unable to load page.
Root Cause:
The Event Team Member object record does not have a record type.
Solution:
Assign the Event Team Member object record a record type.
Additionally, make sure there is a default record type set on the profile level. It should not be the --Master-- record type.
Related Documentation:
CRM Help Documentation: Event Team Members
Article: The Record Type of Automatically-Created Event Team Member Record is Null in CRM Online