Overview:
When accessing Veeva functionality that requires pages to be loaded from an S-Control or VisualForce Page, the end-user encounters either of the two errors:
No message body writer has been found for class com.veevasystems.api.response.ErrorResponse, ContentType: */*
Error establishing connection to Salesforce.
Examples:
Root Cause:
In most cases, the error occurs if the API Requests has reached the Org's limit.
If the API Request limit has not been reached, the end-user needs API access to utilize certain functionalities within the CRM Online application.
Solution:
Provide API Enabled System Permissions for the user either through the Profile or designated Permission Set.
Related Documentation:
Knowledge Article: Error: Error establishing connection to Salesforce - When Accessing CRM Platform Online