Overview:
On CRM for iPad, the Product Metrics on an Account Detail page is not visible due to the following error:
ERROR: Too Many values for Metric Configuration {{0}}.
Root Cause:
The user is missing Field Level Security (FLS) access to the Metric_Configuration_vod__c.Product_vod__c field.
Solution:
Grant, as a minimum, read FLS to the Metric_Configuration_vod__c.Product_vod__c field:
- As a System Administrator, open the affected user profile.
- Under the Field-Level Security section, click View next to Metric Configuration.
- Click Edit.
- Check the boxes to grant Read/Edit access.
- Click Save.
- Clear the Veeva Cache.
- Refresh the database with the user.
Related Documentation:
CRM Help Documentation: Creating Product-Specific Metrics Configurations