Overview:
The user clicks on the Edit button in the Territory Specific Field (TSF) record section on the Account Page and the following error message appears:
Unable to Load Page
[Error extendedErrorDetails='{[0]}' fields='{[0]}' message='entity type cannot be inserted: Territory Field' statusCode='CANNOT_INSERT_UPDATE_ACTIVATE_ENTITY' ]
Root Cause:
The user does not have Create object permission on the Territory Fields object.
In case the TSF fields are blank, the end-user does not have any TSF record and the user needs Create permission to create a record.
Solution:
Do the following:
- Provide Create object permission to the Territory Fields object for the end-user.
- Clear Veeva Cache.
Related Documentation:
CRM Help Documentation: N/A