Overview:
Detail Products not marked as favorite on My Setup show on the favorite products section of the Call Report.
Root Cause:
This happens when the user does not have Field Level Security (FLS) access to the field Favorite_vod__c field on the My_Setup_Products_vod__c object.
Solution:
As per documentation, end-users should have Read/Edit FLS access to the field.
Related Documentation:
CRM Help Documentation: Detail Favorites