Overview:
Assortment values are not populating when creating orders in Veeva CRM.
Root Cause:
The Account_Record_Type_vod API Name picklist values does not match the record type names in the Account object.
Solution:
Have an Assortment record that exists for users with valid Start and End Dates.
When using custom account record types, verify if the API Name picklist values match the account record type name in the Assortment_vod__c.Account_Record_Type_vod__c field.
Related Documentation:
CRM Help Documentation: Order Assortments