Overview:
A content download error occurs while downloading presentations with the Veeva CRM Desktop Application.
Root Cause:
The maximum file path length for Windows is 260 characters. The issue is that the full path includes the file name and username and exceeds this maximum value in Windows.
The path structure is as follows:
[Drive]:\Users\\AppData\Local\
On the Operating System of the end-user, with Command Prompt (CMD) it is possible to determine the length of the file location:
- Navigate to the desired folder/file:
C:\Users\\AppData\Local\VeevaCRMEngage\app-[version]\[sfdc user name]\Media\[sfdc id]\[folder]\[folder]\[thumb.png] - Run the following command to get the full path for each file: dir /S /B
- In the result, locate the longest file path and use Notepad to count the number of total characters.
Solution:
This is a limitation of the Windows Operating System and cannot be bypassed. In order to resolve the issue, reduce the path length either by shortening the username or the filename of the Key Message content.
Related Documentation:
CRM Help Documentation:
Microsoft Documentation:
Knowledgebase:
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