Overview:
A content download error occurs while downloading presentations with the Veeva CRM Engage Application.
Root Cause:
The maximum file path length for Windows is 260 characters. The issue is because the full path includes the file name and username and exceeds this maximum value in Windows.
The path structure is as follows:
[Drive]:\Users\\AppData\Local\
On the Operating System of the end-user, with Command Prompt (CMD) it is possible to determine the length of the file location:
1. Navigate to the desired folder/file:
C:\Users\\AppData\Local\VeevaCRMEngage\app-[version]\[sfdc user name]\Media\[sfdc id]\[folder]\[folder]\[thumb.png]
2. Run the following command to get the full path for each file: dir /S /B
3. In the result, locate the longest file path and use Notepad to count the number of total characters.
Solution:
This is a limitation of the Windows Operating Systems and cannot be bypassed. In order to resolve the issue, reduce the path length either by shortening the username or the filename of the Key Message content.
Related Documentation:
- CRM Help Documentation: Configuring CLM for Online Engage Meetings
- Microsoft Documentation: Naming Files, Paths, and Namespaces
- Knowledge Article #1: Content Unzips Properly in CRM iRep but Fails in WinModern
- Knowledge Article #2: How to Retrieve CRM Crash Log on Windows for Veeva Engage App?
Send us your feedback: We are always looking for feedback to help improve our Knowledge Base! Please let us know if this article is helpful or provide feedback on how we can improve your experience by clicking here.