Overview:
The Favorite field is not available on the creation Page of Veeva Align Territory Or Field Force Products. The assignment may be created from the side of the Product record.
Root Cause:
The issue is caused because the Favorite field not placed on the Territory Product or Field Force Product related lists of the Product object.
Solution:
Be sure to add the Favorite field to the Territory Product or Field Force Product related lists of the Product object.
Related Documentation:
Align Help Documentation: Configuring Align