Overview:
An error occurs when refreshing layout rules on the Event Configuration Page in CRM Online: Layout Rules Could Not Be Refreshed. Please Review Logs for More Information.
Root Cause:
The Event Administrator may lack the Field-Level Security (FLS) read permission to the following fields on the EM_Event_Layout_vod object:
- Country_Override_vod
- Event_Layout_vod
- Event_Object_Name_vod
- Event_Configuration_vod
- Event_Status_vod
- Event_Team_Role_vod
- Expense_Estimate_Layout_vod
- Expense_Header_Layout_vod
- Expense_Line_Layout_vod
- Page_Layout_vod
- Record_Type_vod
- Visible_Buttons_vod
Solution:
Be sure the Event Administrator has FLS read permission for all these fields mentioned above.
Related Documentation:
CRM Help Documentation: Event Layout Rules Caching