Overview:
When an Event Attendee clicks on the RSVP links in the Approved Email sent from the Event, the corresponding Status field on the Event Attendee record is not updating.
Root Cause:
The RSVP links in the Approved Document is referencing Multichannel Message records. When the recipient clicks on a link, the Status_vod__c field on the EM_Attendee_vod__c object record is updated based on the value of the Event_Attendee_Status_vod__c field on the Multichannel_Message_vod__c object. The two picklist fields should contain identical values. The EM_Attendee_vod__c object record is updated by the Integration User. If the Status_vod field is not updated, the Integration User can have insufficient permissions to the required fields.
The process can also fail if there is a custom Validation Rule that prevents updating the EM_Attendee_vod__c/Event_Attendee_vod__c records if the criteria are not met.
Solution:
Grant FLS Edit access for the Integration User to the following fields on the Sent_Email_vod__c object:
- EM_Event_vod__c
- Medical_Event_vod__c
- EM_Attendee_vod__c
- Event_Attendee_vod__c
- EM_Event_Team_Memember_vod__c
- EM_Event_Speaker_vod__c
- User_vod__c
Review the Validation Rules on the EM_Attendee_vod__c/Event_Attendee_vod__c objects to see if there is anything that is interfering with the Integration User to update the records.
Related Documentation:
CRM Help Documentation: Using Approved Email for Events Management