Overview:
MyInsights reports are not displayed on the Veeva CRM WinModern app. The user has access to the related HTML Report record and the app syncs both the HTML Report and the related attachment.
Root Cause:
The Include Attachments checkbox is checked on the HTML Report VMOC record, which is causing the app to sync the related attachment twice, making the Body field on the attachment empty and invalid.
Solution:
The Include Attachments checkbox must be set to 'false' on the Windows HTML Report VMOC and the user must not have access to 2 Attachment VMOCs that download the same HTML Report attachment to avoid the issue.
Related Documentation:
CRM Help Documentation: Configuring MyInsights for Admins and End Users