Overview:
While logging a call from the Calls tab for any record type, the following error occurs:
Action not allowed. An account or medical event must be selected before a call can be created.
Root Cause:
It is not possible to log a Call from the Salesforce Calls tab.
Solution:
New Calls can be logged from the My Accounts list, Account Detail page, Call Objective, Medical Inquiry or a Medical Event.
Related Documentation:
CRM Help Documentation: Call Reporting Overview