Overview:
When opening the map from the Online Agenda View, the address of one or more Accounts is missing.
Root Cause:
The Address_vod__c field is not populated on the Territory Specific Field (TSF_vod__c) record of the affected Accounts.
Solution:
The addresses which appear on the Map are coming from the Territory Specific Field (TSF_vod__c) records of each Account. In order to make the address of an Account visible on the Map, the Address_vod__c field of the TSF_vod__c record which belongs to that Account must be populated.
Related Documentation:
CRM Help Documentation: N/A