Overview:
An end-user encounters an error message when activating a Contract record:
VEEVA_CONTRACT_AFTER_UPDATE: execution of AfterUpdate caused by: System.DmlException: Update failed. First exception on row # with id "18-digit record Id"; first error: FIELD_FILTER_VALIDATION_EXCEPTION, Value does not exist or does not match filter criteria.: [Product_vod__c].
Root Cause:
An associated Contract Line record has a Product_vod__c that does not meet the Veeva-defined filter criteria for the Product_vod field in the Contract_Line_vod object.
Solution:
- Navigate to the Contract_Line_vod record that is causing the error message.
- Be sure the Product_vod record meets the Veeva-defined filter criteria.
Filter Criteria:
Related Documentation:
CRM Help Documentation: Contract Lifecycle